import Foundation
let pattern = #"(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Lorem 1:06:16 ips48:5um."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 <span class="time">$2</span> $3<span class="time">$4</span>$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)