package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)`)
var str = `Lorem 1:06:16 ips48:5um.`
var substitution = "$1 <span class="time">$2</span> $3<span class="time">$4</span>$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}