# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)"
test_str = "Lorem 1:06:16 ips48:5um."
subst = "$1 <span class=\"time\">$2</span> $3<span class=\"time\">$4</span>$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.