use strict;
my $str = 'Lorem 1:06:16 ips48:5um.';
my $regex = qr/(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)/mp;
my $subst = '$1 <span class="time">$2</span> $3<span class="time">$4</span>$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";