// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+?)\s+(\d+:\d+:\d+)\s+(.+?)(\d+:\d+)(\S+)").unwrap();
let string = "Lorem 1:06:16 ips48:5um.";
let substitution = "$1 <span class=\"time\">$2</span> $3<span class=\"time\">$4</span>$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}