# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(IN\s+\(|,)\s*([^,]+)\s*/$1sha1($2)/igm;t' <<< "SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )"