import Foundation
let pattern = #"(?i)(IN\s+\(|,)\s*([^,]+)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1sha1($2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)