// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(?i)(IN\s+\(|,)\s*([^,]+)\s*").unwrap();
let string = "SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )";
let substitution = "$1sha1($2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}