package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?i)(IN\s+\(|,)\s*([^,]+)\s*`)
var str = `SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )`
var substitution = "$1sha1($2)"
fmt.Println(re.ReplaceAllString(str, substitution))
}