use strict;
my $str = 'SELECT msg FROM mytable WHERE id IN (\'hello\', \'world\', 123, 456 , 789 )';
my $regex = qr/(?i)(IN\s+\(|,)\s*([^,]+)\s*/imp;
my $subst = '$1sha1($2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";