#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?i)(IN\s+\(|,)\s*([^,]+)\s*"
Local $sString = "SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )"
Local $sSubst = "$1sha1($2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)