import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(IN\\s+\\(|,)\\s*([^,]+)\\s*";
final String string = "SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )";
final String subst = "$1sha1($2)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}