$re = '/(?i)(IN\s+\(|,)\s*([^,]+)\s*/im';
$str = 'SELECT msg FROM mytable WHERE id IN (\'hello\', \'world\', 123, 456 , 789 )';
$subst = "$1sha1($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;