re = /(?i)(IN\s+\(|,)\s*([^,]+)\s*/im
str = 'SELECT msg FROM mytable WHERE id IN (\'hello\', \'world\', 123, 456 , 789 )'
subst = '$1sha1($2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result