using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(IN\s+\(|,)\s*([^,]+)\s*";
string substitution = @"$1sha1($2)";
string input = @"SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}