const regex = /(?i)(IN\s+\(|,)\s*([^,]+)\s*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(IN\\s+\\(|,)\\s*([^,]+)\\s*', 'igm')
const str = `SELECT msg FROM mytable WHERE id IN ('hello', 'world', 123, 456 , 789 )`;
const subst = `$1sha1($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);