#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{[^}{]*}(*SKIP)(*F)|,"
Local $sString = "{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}" & @CRLF & _
"{f,o,o} b,a,r {b,a,z}" & @CRLF & _
"{{a,a},{b,b},{c,c}}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)