import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}\\{]*\\}(*SKIP)(*F)|,";
final String string = "{\"A\": \"B\", \"C\":{\"D\":\"E\"}, \"F\": {\"G\"}, \"H\":\"I\"}\n"
+ "{f,o,o} b,a,r {b,a,z}\n"
+ "{{a,a},{b,b},{c,c}}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}