$re = '/{[^}{]*}(*SKIP)(*F)|,/';
$str = '{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;