import Foundation
let pattern = #"{[^}{]*}(*SKIP)(*F)|,"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)