re = /{[^}{]*}(*SKIP)(*F)|,/
str = '{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result