const regex = /{[^}{]*}(*SKIP)(*F)|,/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{[^}{]*}(*SKIP)(*F)|,', 'g')
const str = `{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);