using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^}{]*}(*SKIP)(*F)|,";
string substitution = @"";
string input = @"{""A"": ""B"", ""C"":{""D"":""E""}, ""F"": {""G""}, ""H"":""I""}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}