use strict;
my $str = '{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
';
my $regex = qr/{[^}{]*}(*SKIP)(*F)|,/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";