package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{[^}{]*}(*SKIP)(*F)|,`)
var str = `{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}
{f,o,o} b,a,r {b,a,z}
{{a,a},{b,b},{c,c}}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}