# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>\s*\n\s*(\w.*\w)\s*\n\s*</>\1</g;t' <<< "<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>"