import Foundation
let pattern = #">\s*\n\s*(\w.*\w)\s*\n\s*<"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #">\1<"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)