import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\s*\\n\\s*(\\w.*\\w)\\s*\\n\\s*<";
final String string = "<input>\n"
+ " <program_name>\n"
+ " CS\n"
+ " </program_name>\n"
+ " <course_name>\n"
+ " ART CLASS\n"
+ " </course_name>\n"
+ " <instructor>\n"
+ " John Smith\n"
+ " </instructor>\n"
+ "</input>";
final String subst = ">\\1<";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}