re = />\s*\n\s*(\w.*\w)\s*\n\s*</
str = '<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>'
subst = '>\\1<'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result