use strict;
my $str = '<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>';
my $regex = qr/>\s*\n\s*(\w.*\w)\s*\n\s*</p;
my $subst = '>\\1<';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";