const regex = />\s*\n\s*(\w.*\w)\s*\n\s*</g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>\\s*\\n\\s*(\\w.*\\w)\\s*\\n\\s*<', 'g')
const str = `<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>`;
const subst = `>\1<`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);