package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>\s*\n\s*(\w.*\w)\s*\n\s*<`)
var str = `<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>`
var substitution = ">\1<"
fmt.Println(re.ReplaceAllString(str, substitution))
}