#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ">\s*\n\s*(\w.*\w)\s*\n\s*<"
Local $sString = "<input>" & @CRLF & _
" <program_name>" & @CRLF & _
" CS" & @CRLF & _
" </program_name>" & @CRLF & _
" <course_name>" & @CRLF & _
" ART CLASS" & @CRLF & _
" </course_name>" & @CRLF & _
" <instructor>" & @CRLF & _
" John Smith" & @CRLF & _
" </instructor>" & @CRLF & _
"</input>"
Local $sSubst = ">\1<"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)