using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">\s*\n\s*(\w.*\w)\s*\n\s*<";
string substitution = @">\1<";
string input = @"<input>
<program_name>
CS
</program_name>
<course_name>
ART CLASS
</course_name>
<instructor>
John Smith
</instructor>
</input>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}