# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+) ?(\d{1,2} ?-)(\d{1,2})/\1 \2\1 \3/gm;t' <<< "I only work between September 12 -14 at this place. I will be back between May 10-15 next year."