const regex = /(\w+) ?(\d{1,2} ?-)(\d{1,2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+) ?(\\d{1,2} ?-)(\\d{1,2})', 'gm')
const str = `I only work between September 12 -14 at this place. I will be back between May 10-15 next year.`;
const subst = `\1 \2\1 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);