import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+) ?(\\d{1,2} ?-)(\\d{1,2})";
final String string = "I only work between September 12 -14 at this place. I will be back between May 10-15 next year.";
final String subst = "\\1 \\2\\1 \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}