use strict;
my $str = 'I only work between September 12 -14 at this place. I will be back between May 10-15 next year.';
my $regex = qr/(\w+) ?(\d{1,2} ?-)(\d{1,2})/mp;
my $subst = '\\1 \\2\\1 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";