#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+) ?(\d{1,2} ?-)(\d{1,2})"
Local $sString = "I only work between September 12 -14 at this place. I will be back between May 10-15 next year."
Local $sSubst = "\1 \2\1 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)