using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+) ?(\d{1,2} ?-)(\d{1,2})";
string substitution = @"\1 \2\1 \3";
string input = @"I only work between September 12 -14 at this place. I will be back between May 10-15 next year.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}