import Foundation
let pattern = #"(\w+) ?(\d{1,2} ?-)(\d{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I only work between September 12 -14 at this place. I will be back between May 10-15 next year."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2\1 \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)