// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+) ?(\d{1,2} ?-)(\d{1,2})").unwrap();
let string = "I only work between September 12 -14 at this place. I will be back between May 10-15 next year.";
let substitution = "\\1 \\2\\1 \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}