package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+) ?(\d{1,2} ?-)(\d{1,2})`)
var str = `I only work between September 12 -14 at this place. I will be back between May 10-15 next year.`
var substitution = "\1 \2\1 \3"
fmt.Println(re.ReplaceAllString(str, substitution))
}