$re = '/(\w+) ?(\d{1,2} ?-)(\d{1,2})/m';
$str = 'I only work between September 12 -14 at this place. I will be back between May 10-15 next year.';
$subst = "\1 \2\1 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;