# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+) ?(\d{1,2} ?-)(\d{1,2})"
test_str = "I only work between September 12 -14 at this place. I will be back between May 10-15 next year."
subst = "\\1 \\2\\1 \\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.