# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/(sites\\/?)?(.*)$/\/sites\/\2/mg;t' <<< "/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global"