import Foundation
let pattern = #"^\/(sites\/?)?(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/sites/\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)