const regex = /^\/(sites\/?)?(.*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(sites\\\/?)?(.*)$', 'mg')
const str = `/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global`;
const subst = `/sites/\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);