// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/(sites\/?)?(.*)$").unwrap();
let string = "/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global";
let substitution = "/sites/\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}