re = /^\/(sites\/?)?(.*)$/m
str = '/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/global'
subst = '/sites/\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result